Absolute new installation and DAHDI dead.

Support forum for the ViciBox ISO Server Install and ISO LiveCD Demo

Moderators: enjay, williamconley, Staydog, mflorell, MJCoate, mcargile, Kumba

Absolute new installation and DAHDI dead.

Postby kvar » Sat Jul 04, 2020 3:13 pm

I have just finished a fresh installation of ViciBox_v9.x86_64-9.0.3.iso

I am on Installation manual page 7 : ViciDial Express Installation

There are no logged errors
Clean reboot
I have logged in vicidial administration page succesfully

Before start the next configuration steps I had a look on the status of DAHDI:

vicibox9:/home/kvar # /etc/init.d/dahdi status
Checking for dahdi ... modules loaded. running
● dahdi.service - LSB: Load and initialize Dahdi.
Loaded: loaded (/etc/init.d/dahdi; generated; vendor preset: disabled)
Active: inactive (dead)
Docs: man:systemd-sysv-generator(8)
vicibox9:/home/kvar # /etc/init.d/dahdi start
redirecting to systemctl start dahdi.service
vicibox9:/home/kvar # /etc/init.d/dahdi status
Checking for dahdi ... modules loaded. running
● dahdi.service - LSB: Load and initialize Dahdi.
Loaded: loaded (/etc/init.d/dahdi; generated; vendor preset: disabled)
Active: active (exited) since Sat 2020-07-04 22:49:32 EEST; 7s ago
Docs: man:systemd-sysv-generator(8)
Process: 3354 ExecStart=/etc/init.d/dahdi start (code=exited, status=0/SUCCESS)
vicibox9:/home/kvar #

Is that normal? Please advice before continue all the next configuration steps.

Thank you.
kvar
 
Posts: 20
Joined: Sat Jun 27, 2020 8:01 am

Re: Absolute new installation and DAHDI dead.

Postby carpenox » Sat Jul 04, 2020 7:11 pm

Service dahdi enable
2 x Intel Xeon X3450 at 2.66GHz | 16GB DDR4
ViciBox v9.0.3 | Version: 2.14-772a | BUILD: 201004-1045 | SVN Version: 3304 | DB Schema Version: 1608 | Asterisk 13.34.0
http://www.CyburityLLC.com -: 844-PC-SATA-2 - :- www.contactcentersRus.com
carpenox
 
Posts: 698
Joined: Wed Apr 08, 2020 2:02 am
Location: Coral Springs, FL

Re: Absolute new installation and DAHDI dead.

Postby kvar » Sun Jul 05, 2020 6:58 am

Finally I found that the following status of DAHDI module means that it is working.
The campaign call succeded.

/home/kvar # /etc/init.d/dahdi status
Checking for dahdi ... modules loaded. running
● dahdi.service - LSB: Load and initialize Dahdi.
Loaded: loaded (/etc/init.d/dahdi; generated; vendor preset: disabled)
Active: active (exited) since Sat 2020-07-04 22:49:32 EEST; 7s ago
kvar
 
Posts: 20
Joined: Sat Jun 27, 2020 8:01 am

Re: Absolute new installation and DAHDI dead.

Postby carpenox » Sun Jul 05, 2020 11:21 am

Good postback, glad everything is working for ya
2 x Intel Xeon X3450 at 2.66GHz | 16GB DDR4
ViciBox v9.0.3 | Version: 2.14-772a | BUILD: 201004-1045 | SVN Version: 3304 | DB Schema Version: 1608 | Asterisk 13.34.0
http://www.CyburityLLC.com -: 844-PC-SATA-2 - :- www.contactcentersRus.com
carpenox
 
Posts: 698
Joined: Wed Apr 08, 2020 2:02 am
Location: Coral Springs, FL

Re: Absolute new installation and DAHDI dead.

Postby Kumba » Mon Jul 06, 2020 10:14 am

So dahdi is loaded by the vicidial init script, not the dahdi init script.

After you ran vicibox-install, did you reboot? If you didn't, that's why DAHDI wasn't loaded.
Kumba
 
Posts: 871
Joined: Tue Oct 16, 2007 11:44 pm
Location: Florida


Return to ViciBox Server Install and Demo

Who is online

Users browsing this forum: No registered users and 11 guests