Vicibox v.9.0.3 Released June 30th, 2020

Support forum for the ViciBox ISO Server Install and ISO LiveCD Demo

Moderators: enjay, williamconley, Staydog, mflorell, MJCoate, mcargile, Kumba

Vicibox v.9.0.3 Released June 30th, 2020

Postby Kumba » Fri Sep 13, 2019 2:14 pm

*** NOTICE *** This thread isn't for trouble shooting. Start a new thread with your issue and search for relevant issues.

So it's Friday the 13th and there's a full moon. Sounds like a good opportunity to release some software.

ViciBox v.9.0.0 is officially released. A first-boot wizard was added that wasn't in beta3 but the rest is pretty much the same.

Please keep in mind that ViciBox v.9.0 diverges quite significantly from how all previous versions of ViciBox installed. The good news is that the installer is more foolproof but for the advanced users who liked installing onto Linux MD RAID arrays or doing other pre-install things you are somewhat out of luck. Below are the links for the ISO, MD5, and the new installation manual. At a minimum I would suggest you read the first two pages of the manual to get a good understanding on what all has changed and the new restrictions in ViciBox v.9.0.

ISO: http://download.vicidial.com/iso/vicibo ... -9.0.3.iso
MD5: http://download.vicidial.com/iso/vicibo ... -9.0.3.md5
Manual: http://download.vicidial.com/iso/vicibo ... nstall.pdf


There are some restrictions to installing ViciBox v.9.0 now. The first major issues come from PHP7 compatibility with the ViciDial code base itself. The second issue is that Asterisk v.11 isn't compiling on any version of OpenSuSE after v.42.3. This is gone over in more detail in the manual but worst case scenario you will need to do an SVN upgrade to use ViciBox v.9.0.

The short version of the restrictions are:
- If used only as a database server, can be used in any cluster regardless of SVN revision
- If used as a Telephony (asterisk) server, must use at least SVN revision 2960
- If used as a Web server, must use at least SVN revision 3133


So how do you know which SVN revision you have? You can check that by doing the following :
1) Log into your ViciDial web interface as an admin user
2) Go to Admin --> System Settings
3) You'll see the "SVN Version" listed two lines down from the top.
Kumba
 
Posts: 871
Joined: Tue Oct 16, 2007 11:44 pm
Location: Florida

Re: Vicibox v.9.0.0 Released

Postby williamconley » Fri Sep 13, 2019 2:42 pm

Kumba wrote:So it's Friday the 13th and there's a full moon.

And let's not forget that we're expecting a Meteor today. Trifecta.
Vicidial Installation and Repair, plus Hosting and Colocation
Newest Product: NonDisruptive Lead Loader for Enterprise Vicidial Clusters.
(IE: Keep on dialing even while loading large lists!)
http://www.PoundTeam.com # 352-269-0000 # +44(203) 769-2294
williamconley
 
Posts: 19603
Joined: Wed Oct 31, 2007 4:17 pm
Location: Davenport, FL (By Disney!)

Re: Vicibox v.9.0.0 Released

Postby Kumba » Fri Sep 13, 2019 2:51 pm

williamconley wrote:
Kumba wrote:So it's Friday the 13th and there's a full moon.

And let's not forget that we're expecting a Meteor today. Trifecta.


The day just keeps getting better!
Kumba
 
Posts: 871
Joined: Tue Oct 16, 2007 11:44 pm
Location: Florida

Re: Vicibox v.9.0.0 Released

Postby mariusmarais » Tue Oct 01, 2019 1:25 pm

I've been playing with a new 9.0 installation in a hosted (physical) server environment, and the lack of RAID support in the installer is quite a problem for me. In this environment hardware RAID cards are very difficult to come by and we've used Linux mdraid very successfully across a number of workloads for a long time.

(I had originally hoped to use Raider to convert the single-disk installation to RAID10, but it does not support UEFI, which is used in 9.0 by default.)

Is there any way to release a "not quite fool-proof" installer where RAID can be setup or alternatively, would it be possible to load RAID support in the installer? That way I can pre-create the disks with a live CD and then just do the installation using the installer to the RAID disk?

Lastly, is it possible to install OpenSuse first, and then run the Vicibox installer scripts over that? I realise this is not what VB is designed for, but it is very well put together and all the other available installation guides are extremely outdated, or just contain bad advice.

Thanks
mariusmarais
 
Posts: 16
Joined: Mon Aug 19, 2019 8:24 am

Re: Vicibox v.9.0.0 Released

Postby Kumba » Wed Oct 02, 2019 12:24 am

mariusmarais wrote:Is there any way to release a "not quite fool-proof" installer where RAID can be setup or alternatively, would it be possible to load RAID support in the installer? That way I can pre-create the disks with a live CD and then just do the installation using the installer to the RAID disk?



Unfortunately the installer limitation is imposed on me by the previous installer basically being end of life'd by SuSE. The yast2-live-installer basically went end of life in OpenSuSE v.42.1 (ViciBox 7), but I was able to patch it up and keep it working with OpenSuSE v.42.3 (ViciBox 8). The current kiwi build targets are either VM images/containers, a LiveISO with no install option at all, or the pre-configured drive image installer.

There is an option in kiwi to build ViciBox with a pre-configured MD RAID array but it's been found to be temperamental. Some hardware it works great and just installs, and some hardware not so much. Since ViciBox v.9.0 has been relatively stable so far after release I might build an alternate/experimental version with the MD RAID array pre-built in it just to see if anyone else has better results with it. It should be noted that once OpenSuSE gets installed it will essentially be as stable as a brick. It's achilles heal has always been a somewhat finicky install. I blame it's Slackware roots for that.

As far as a boot-strap script goes, there's just too many issues that can arise from those. To really get ViciBox to perform as well as it does requires sysconfig changes, tweaking of install directories and config files, and tons of dependency issues. It's just too easy to end up with a broken installer for reasons you can't control. Most notoriously if the pre-existing install uses a repo with a package installed that conflicts with something ViciDial needs. The other problem is repo and internet reliability. SuSE does occasionally break the repo's and leave them in that state for up to weeks sometimes. You could end up with an unusable or uninstallable system because of it. It could certainly be done, but it would require a level of diligence during the install that I don't think it would get.

I did start writing some instructions to try and convert a single-drive install to an MD RAID-1 but it's not working. It's current state is that when I go to reboot it never mounts the MD device for root, just the single-drive for root. The cause appears to be grub specifying the wrong root= line even though all the configs I can find look correct. I might make a separate post with that in case anyone else out there wants to trouble shoot what I have so far.
Kumba
 
Posts: 871
Joined: Tue Oct 16, 2007 11:44 pm
Location: Florida

Re: Vicibox v.9.0.0 Released

Postby Kumba » Wed Oct 02, 2019 1:44 am

In fact, here you go. An experimental ViciBox v.9.0.0 build with a Linux MD RAID array:

viewtopic.php?f=8&t=39638
Kumba
 
Posts: 871
Joined: Tue Oct 16, 2007 11:44 pm
Location: Florida

Re: Vicibox v.9.0.0 Released

Postby mariusmarais » Wed Oct 02, 2019 1:48 am

Yes, I understand the dilemma.

Thanks for the build, will test and report back on that topic!
mariusmarais
 
Posts: 16
Joined: Mon Aug 19, 2019 8:24 am

Re: Vicibox v.9.0.2 Released April 16th, 2020

Postby Acidshock » Sun Apr 19, 2020 5:23 pm

Not sure if this is the case for everyone but I noticed this missing in the cron after deploying from 9.0.2:

### keepalive script for astguiclient processes
* * * * * /usr/share/astguiclient/ADMIN_keepalive_ALL.pl
VERSION: 2.14-698a | BUILD: 190207-2301 | Asterisk:13.24.1-vici | Vicibox 8.1.2
Acidshock
 
Posts: 398
Joined: Wed Mar 03, 2010 3:19 pm

Re: Vicibox v.9.0.2 Released April 16th, 2020

Postby Kumba » Mon Apr 20, 2020 12:48 pm

I just double checked on a fresh install and the keepalive is there. If you are sure it wasn't a fluke, start a new thread detailing the options you used to install.
Kumba
 
Posts: 871
Joined: Tue Oct 16, 2007 11:44 pm
Location: Florida

Re: Vicibox v.9.0.2 Released April 16th, 2020

Postby carpenox » Mon Apr 20, 2020 5:09 pm

released on another meteor day....fun
2 x Intel Xeon X3450 at 2.66GHz | 16GB DDR4
ViciBox v9.0.3 | Version: 2.14-772a | BUILD: 201004-1045 | SVN Version: 3305 | DB Schema Version: 1608 | Asterisk 13.34.0
http://www.CyburityLLC.com -: 844-PC-SATA-2 - :- www.contactcentersRus.com
carpenox
 
Posts: 706
Joined: Wed Apr 08, 2020 2:02 am
Location: Coral Springs, FL

Re: Vicibox v.9.0.2 Released April 16th, 2020

Postby bmorrison » Thu Apr 23, 2020 8:47 pm

Acidshock wrote:Not sure if this is the case for everyone but I noticed this missing in the cron after deploying from 9.0.2:

### keepalive script for astguiclient processes
* * * * * /usr/share/astguiclient/ADMIN_keepalive_ALL.pl


This happened to me too.

My guess is the vicibox-certbot script lopped it off. This is just a guess as I did not try to log in as an agent until after I had set up the webphones and got the webRTC error message. Checked crontabs and the keep alive was gone.

Pasting it back in fixed my problem, btw.
bmorrison
 
Posts: 94
Joined: Wed Jul 09, 2008 11:26 pm
Location: United States

Re: Vicibox v.9.0.2 Released April 16th, 2020

Postby Smartercom » Fri Apr 24, 2020 5:28 am

Hi i'm testing last release on cluster for 30 agents 1 Dial and 1 WebDB i'm testing Vicidial Firewall with Dynamic List and think this feature is amazing but i have some questions:

1) with dynamic list i have web server opened on port 81 and 80 and 443?Following guide i protect only Dial server but WebDB server is reacheble...how can i protect it? if i use same procedure for WebDB it cannot connect to Dial even if i insert ip of Dial in whitelist..Can you help me?

2)Where is phpMyAdmin? i have installed from advanced installer and choose yes for install phpmyadmin, packet is installed but directory /srv/www/htdocs is empty and if i try to rech phpmyadmin page i receive 404 not found.Can you help me?


Thanks a lot
Smartercom
 
Posts: 24
Joined: Mon Apr 20, 2020 9:51 am

Re: Vicibox v.9.0.2 Released April 16th, 2020

Postby Smartercom » Fri Apr 24, 2020 10:24 am

Smartercom wrote:1) with dynamic list i have web server opened on port 81 and 80 and 443?Following guide i protect only Dial server but WebDB server is reacheble...how can i protect it? if i use same procedure for WebDB it cannot connect to Dial even if i insert ip of Dial in whitelist..Can you help me?



Resolved question for firewall issue, i have opened port 3306 on WebDb and all is working now...wainting for phpmyadmin questions please
Smartercom
 
Posts: 24
Joined: Mon Apr 20, 2020 9:51 am

Re: Vicibox v.9.0.2 Released April 16th, 2020

Postby Kumba » Fri Apr 24, 2020 3:44 pm

This thread isn't really for trouble shooting. Can you post your issue in a new thread?
Kumba
 
Posts: 871
Joined: Tue Oct 16, 2007 11:44 pm
Location: Florida

Re: Vicibox v.9.0.2 Released April 16th, 2020

Postby Smartercom » Thu Apr 30, 2020 2:29 am

thanks a lot, i have opened new thread, sorry for it.
Smartercom
 
Posts: 24
Joined: Mon Apr 20, 2020 9:51 am

Re: Vicibox v.9.0.2 Released April 16th, 2020

Postby GenXOutsourcing » Thu Jun 18, 2020 9:06 am

Acidshock wrote:Not sure if this is the case for everyone but I noticed this missing in the cron after deploying from 9.0.2:

### keepalive script for astguiclient processes
* * * * * /usr/share/astguiclient/ADMIN_keepalive_ALL.pl

Same happened with my new install.

Used the ‘vicibox-install', Database, Web and Telephony and no Archive. Checked screens and asterisk, all was normal. After installing CertBot and the DGG firewall, Asterisk stopped working and only showed 2 screens. Ran perl /usr/share/astguiclient/ADMIN_keepalive_ALL.pl --debug and Asterisk started working again.

The keepalive was missing from crontab, readded it and back to normal.
Single Server/Scratch install Centos6
12 core/32gb RAM/500gb SSD
SVN Version:3133
VERSION: 2.14-718a
BUILD: 190902-0839
GenXOutsourcing
 
Posts: 18
Joined: Sun Sep 22, 2019 12:53 am


Return to ViciBox Server Install and Demo

Who is online

Users browsing this forum: No registered users and 19 guests