Vicibox v.4.0 Patch and Bugfix thread - Updated July 7 2013

Support forum for the ViciBox ISO Server Install and ISO LiveCD Demo

Moderators: enjay, williamconley, Staydog, mflorell, MJCoate, mcargile, Kumba

Vicibox v.4.0 Patch and Bugfix thread - Updated July 7 2013

Postby Kumba » Wed Feb 06, 2013 3:09 pm

This thread will contain information on patching ViciBox v.4.0 where applicable. Please post in a separate thread about any new bugs or issues.

ViciBox v.4.0.1 and under PERL modules for email functionality:
1) zypper refresh
2) zypper in perl-WWW-curl perl-Mail-POP3Client perl-Time-Local perl-HTML-Format perl-HTML-Strip perl-Mail-Box perl-Mail-IMAPClient perl-MIME-tools perl-IO-Socket-SSL perl-MIME-Base64

--------

Vicibox v.4.0.2 64-bit and under archive configuration file location:
1) mv /etc/apache/conf.d/viciarchive.conf /etc/apache2/conf.d/
2) rcapache2 restart

--------

ViciBox v.4.0.2 and under email crontab entry, only do on one server, preferably the database:
1) crontab -l > /root/rootcron
2) echo "### inbound email parser should only be active on a single server" > /root/rootcron
3) echo "* * * * * /usr/share/astguiclient/AST_inbound_email_parser.pl" > /root/rootcron
4) crontab /root/rootcron

--------

ViciBox v.4.0.3 Database-only crontab loading issue, only do on the primary database server:
1) Login as root
2) cat /usr/src/astguiclient/conf/allcron > /tmp/rootcron
3) cat /usr/src/astguiclient/conf/dbcron >> /tmp/rootcron
4) echo "" >> /tmp/rootcron
5) crontab /tmp/rootcron

--------

ViciBox v.4.0 downgrade to MySQL v.5.1:
1) Login as root
2) rcmysql stop
3) cp /etc/init.d/mysql /root/
4) zypper rm mysql-community-server

For 32 bit only:
5) wget -O MySQL-server-5.1.68-1.glibc23.i386.rpm http://dev.mysql.com/get/Downloads/MySQL-5.1/MySQL-server-5.1.68-1.glibc23.i386.rpm/from/http://cdn.mysql.com/
6) zypper in MySQL-server-5.1.68-1.glibc23.i386.rpm

For 64 bit only:
5) wget -O MySQL-server-5.1.68-1.glibc23.x86_64.rpm http://dev.mysql.com/get/Downloads/MySQL-5.1/MySQL-server-5.1.68-1.glibc23.x86_64.rpm/from/http://cdn.mysql.com/
6) zypper in MySQL-server-5.1.68-1.glibc23.x86_64.rpm

7) cp /root/mysql /etc/init.d/mysql
8) mv /etc/my.cnf.rpmsave /etc/my.cnf
9) rcmysql start
10) mysql_upgrade

You can safely ignore the errors about the performance schema tables not being compatible. Those are a MySQL 5.5 specific item and are not used in MySQL v.5.1.

--------

Install new PERL module for the changed login system, All versions of ViciBox below v.5.0 and SVN 1993:
1) zypper in perl-Crypt-Eksblowfish
Kumba
 
Posts: 721
Joined: Tue Oct 16, 2007 11:44 pm
Location: Florida

Re: Vicibox v.4.0 Patch and Bugfix thread

Postby williamconley » Thu Apr 18, 2013 5:43 pm

Bug:

Code: Select all
mysqldump: Got error: 1105: Unknown error when doing refresh


Solution:

Code: Select all
/bin/chmod 655 /var/log/mysql
Vicidial Installation and Repair, plus Hosting and Colocation
SugarCRM integration - Customization and Add-ons - We Bring It All Together.
http://www.PoundTeam.com # 352-269-0000 # +44 (203) 769-2294 # +506 4001-8914
williamconley
 
Posts: 17421
Joined: Wed Oct 31, 2007 4:17 pm
Location: Davenport, FL (By Disney!)

Re: Vicibox v.4.0 Patch and Bugfix thread

Postby Kumba » Thu Apr 18, 2013 10:06 pm

williamconley wrote:Bug:

Code: Select all
mysqldump: Got error: 1105: Unknown error when doing refresh


Solution:

Code: Select all
/bin/chmod 655 /var/log/mysql



So, what conditions should exist for that code to run? Is that something you had to do on a regular install? Or only when downgrading to MySQL v.5.1? Some details are needed.
Kumba
 
Posts: 721
Joined: Tue Oct 16, 2007 11:44 pm
Location: Florida

Re: Vicibox v.4.0 Patch and Bugfix thread

Postby williamconley » Thu Apr 18, 2013 11:22 pm

Kumba wrote:
williamconley wrote:Bug:

Code: Select all
mysqldump: Got error: 1105: Unknown error when doing refresh


Solution:

Code: Select all
/bin/chmod 655 /var/log/mysql



So, what conditions should exist for that code to run? Is that something you had to do on a regular install? Or only when downgrading to MySQL v.5.1? Some details are needed.
As far as I've found it is necessary on all 4.X Vicibox with 5.5. That is the command that makes the database backup start working without having to remove the --flush-logs (which will eventually choke the backup system). We had to fix that before something "bad" happened on a client server. We use 4.0.3 on all new client boxes now. :)
Vicidial Installation and Repair, plus Hosting and Colocation
SugarCRM integration - Customization and Add-ons - We Bring It All Together.
http://www.PoundTeam.com # 352-269-0000 # +44 (203) 769-2294 # +506 4001-8914
williamconley
 
Posts: 17421
Joined: Wed Oct 31, 2007 4:17 pm
Location: Davenport, FL (By Disney!)


Return to ViciBox Server Install and Demo

Who is online

Users browsing this forum: williamconley and 14 guests