ViciBox Install Tips and Tricks, etc

Support forum for the ViciBox ISO Server Install and ISO LiveCD Demo

Moderators: enjay, williamconley, Staydog, mflorell, MJCoate, mcargile, Kumba

ViciBox Install Tips and Tricks, etc

Postby Kumba » Thu Jan 27, 2011 1:06 am

Just some tips and tricks you can use when installing with ViciBox. Should work for most versions above 3.0. You should *NOT* attempt *ANY* of this if you are not familiar with what is being done. If you mess up, the system can become unusable.

You also don't have to do any of this. It's just some of our knowledge we want to share with what we would normally do as part of our standard practice. Most of it has to do with system security and a little functionality. If you have some of your own tips you'd like to share, post an explanation of what you are accomplishing along with a process of how you do it, similar to what I have done for mine.

If you want to discuss the merits of these items, start a new post so that we can keep this one relatively clean and easy to read/use.

----

Disable the frame-buffer modes on grub boot. This has to be done every time a new kernel is installed. Some VGA chipsets (like older ATI ones) have a noticable lag to them and actually causes the system to boot and react slower on the CLI. This is also good as it makes any monitor work irregardless of resolution. DO NOT do this if you are not familiar with what grub or kernels are!
1) pico /boot/grub/menu.lst
2) Find the line that loads your running kernel
3) Remove the line that says vga=<something> and replace it with nomodeset
4) Reboot and enjoy the plain BIOS text output


Disable the default redirect script. This is very important if you run a hosted system, cause it will tell everyone what you are doing when they hit your server's IP. The fix is pretty simple, as it just makes the default what apache had there anyways:
1) echo "<html><body><h1>It works!</h1></body></html>" > /srv/www/htdocs/index.html


Move phpMyAdmin to something else. This prevents people from trying to brute-force their way into your database. Just do the following:
1) mv /srv/www/htdocs/phpMyAdmin /srv/www/htdocs/<something-else>


Use a different username and password for the database other then the defaults, specially if you leave phpMyAdmin in it's default place! Just make sure your password has numbers and letters in it for starters. The seriously security conscious can use a random string from somewhere like strongpasswordgenerator.com (I do), or a passphrase, just keep it under 15 alphanumeric character or MySQL will not take it.


Change the default server "conf file secret" under Admin --> Server. Again have letters and numbers or use a password generator like what was mentioned above. If you have multiple servers, use a different one for each server.


Change the default phone "conf file secret" to something other then the default value. On newer systems you set this at first login, and can control it under Admin --> System Settings. It may also be referred to as "Registration Password" depending upon your vicidial version.


Just use DHCP if you have it during the Phase-1 install, you can always change IP's prior to Phase-2 by typing 'yast lan'. This also allows you to pre-load the servers at one location, then ship them somewhere and do the final config remotely. All you have to do is talk someone through changing the IP's in yast.


The installer can sometimes be finicky about hard-drives that have been repurposed from other things, I.E. non-blank drives. The easiest thing when this happens is to just wipe the partition table of the effected drives, and reboot onto the CD to start the install. DO NOT DO THIS ON A LIVE SYSTEM! It WILL flatten your drive, costing you ALL your data!
1) Boot from ViciBox cd and login as root with password vicidial
2) Type this: dd if=/dev/zero of=/dev/path bs=512 count=1024
3) Reboot from ViciBox CD and proceed with Phase-1 install


Have a real nameserver to use. Otherwise it will cause issues when ViciBox is installing and it detects access to the internet. When in doubt, I use either 4.2.2.1 and/or 8.8.8.8


ENABLE SSH ACCESS TO YOUR MACHINE FROM YOUR FIREWALL FOR REMOTE SUPPORT! Gotomeeting, WebMeeting, TeamViewer, and all of their variants are nice in a windows world, but it only slows down your support technician and limits his ability to work normally. If you really want to watch, just ask him to enable a screen session and watch in a putty window. Just try not to type anything while he's working, we hate that.
Kumba
 
Posts: 721
Joined: Tue Oct 16, 2007 11:44 pm
Location: Florida

Re: ViciBox Install Tips and Tricks, etc

Postby EMSystems » Mon Oct 01, 2012 2:43 am

Thank you for the tips, I am trying to install 4.0.1 standard 64x on a dell poweredge 1950 iii with 4g mem 2 dual 2.0 processors and two 160 gig HD
and my issue is, I preformed the following action
The installer can sometimes be finicky about hard-drives that have been repurposed from other things, I.E. non-blank drives. The easiest thing when this happens is to just wipe the partition table of the effected drives, and reboot onto the CD to start the install. DO NOT DO THIS ON A LIVE SYSTEM! It WILL flatten your drive, costing you ALL your data!
1) Boot from ViciBox cd and login as root with password vicidial
2) Type this: dd if=/dev/zero of=/dev/path bs=512 count=1024
3) Reboot from ViciBox CD and proceed with Phase-1 install

And after doing so continued with the install but when i got to were it gives the "suggested provitioning" there isn't one the White Box is blank and if i continue with the install it starts gets to about 45% and throughs up an Error #3008 and asks if i wish to continue install if i do it just times out at 84% and crashes. and now it just throughs up a grub #17 error in the bios when i start the server. any advice?
EMSystems
 
Posts: 1
Joined: Sun Sep 30, 2012 11:30 pm

Re: ViciBox Install Tips and Tricks, etc

Postby Kumba » Mon Oct 01, 2012 1:08 pm

Sounds like the installer is not finding your hard drives at all. Or you have something else going on. Haven't worked much will Dell servers so can't really comment on them. Do you see the drives in fdisk?
Kumba
 
Posts: 721
Joined: Tue Oct 16, 2007 11:44 pm
Location: Florida

Re: ViciBox Install Tips and Tricks, etc

Postby williamconley » Sat Oct 06, 2012 11:10 pm

It may also be that the order of the drives in the BIOS is wrong. We've had a few incidents where the Vicibox .iso will get part of the way through installation and then (usually during a reboot) claim that there is no drive bootable. Changing the drive boot sequence allows it to find the master boot record and then grub loads.

If all else fails, disconnect all your (SAS/RAID,etc) drives and pop in a single SATA (No other drives except the CD present) and be sure BIOS has permission to boot from this single drive and the CD ... and see if that resolves your issue. That would ordinarily indicate that you are at least on the right track. Then you can battle the BIOS into finding grub properly after confirmation.

Did you get the DRAC card with the Dell? (Handy ...)
Vicidial Installation and Repair, plus Hosting and Colocation
SugarCRM integration - Customization and Add-ons - We Bring It All Together.
http://www.PoundTeam.com # 352-269-0000 # +44 (203) 769-2294 # +506 4001-8914
williamconley
 
Posts: 17433
Joined: Wed Oct 31, 2007 4:17 pm
Location: Davenport, FL (By Disney!)

Re: ViciBox Install Tips and Tricks, etc

Postby tony » Wed Oct 31, 2012 7:50 am

The boot order must be correct, as the poster is seeing a grub error.

Kumba
"and now it just throughs up a grub #17 error in the bios when i start the server."


I would simply try reinstalling - but erase your disk(s) first.

You do need to know the device names to use this command: Type this: dd if=/dev/zero of=/dev/path bs=512 count=1024

They might be /dev/sda, it depends what controller you have in your Dell server.

If so - this is what you want: Type this: dd if=/dev/zero of=/dev/sda bs=512 count=1024

But run this before you do any of the installation - I recommend getting a 'live cd' such as System Rescue CD or similar.
tony
 
Posts: 1
Joined: Wed Oct 31, 2012 7:47 am

Re: ViciBox Install Tips and Tricks, etc

Postby macoy » Wed Feb 19, 2014 4:19 am

Hi All,

Thanks that I found this site after a long searching.

To cut the long story short. I am installing a VICIDIAL 5.0.3 32BIT Standard. Every time I run the installation CD it always stall after 3 minutes loading the LINUX KERNEL. I am installing it from DELL POWEREDGE 1950 server 4GB Memory and 160GB HD.

I get these errors:

KERNEL PANIC - Not Synching Attempt to KILL INIT!

PID: 1, comm: CHROOT NOT TAINTED 3.7.10-1,16-default #1
Call Trace:

Then it'll go to # prompt.

The Hard drive is clean as I run the KILLDISK.

I have not tried the above tips but just wondering if anyone of you have encountered this error? Or maybe can someone can shed some knowledge and assistance. I am new to this VICIBOX.

Please advise and help. Thanks for your time.
macoy
 
Posts: 1
Joined: Wed Feb 19, 2014 4:00 am

Re: ViciBox Install Tips and Tricks, etc

Postby geoff3dmg » Wed Feb 19, 2014 5:18 am

You should of started a new thread. However I've had this issue. The stock SuSE kernel does not include the megaraid modules for the Dell PERC hard drive controlllers. You can fix it by booting up the system with SystemRescueCD. Edit the file '/etc/sysconfig/kernel' and find:

Code: Select all
INITRD_MODULES=


Change it to:

Code: Select all
INITRD_MODULES="megaraid_mm megaraid_mbox"


Then save the file and run 'mkinitrd' to rebuild the initramfs with the correct modules. Reboot and the system will come up cleanly.
Vicibox 5.03 from .iso | VERSION: 2.10-451a BUILD: 140902-0816 | Asterisk 1.8.28.2-vici | Multi-Server | Amfeltec H/W Timing Cards | No Extra Software After Installation | Dell PowerEdge 1850 | Pentium 4 'Prescott' Xenon Quad @ 3.40GHz
geoff3dmg
 
Posts: 403
Joined: Tue Jan 29, 2013 4:35 am
Location: Lancashire, UK

Re: ViciBox Install Tips and Tricks, etc

Postby williamconley » Wed Feb 19, 2014 8:20 pm

macoy wrote:Hi All,

Thanks that I found this site after a long searching.

To cut the long story short. I am installing a VICIDIAL 5.0.3 32BIT Standard. Every time I run the installation CD it always stall after 3 minutes loading the LINUX KERNEL. I am installing it from DELL POWEREDGE 1950 server 4GB Memory and 160GB HD.

I get these errors:

KERNEL PANIC - Not Synching Attempt to KILL INIT!

PID: 1, comm: CHROOT NOT TAINTED 3.7.10-1,16-default #1
Call Trace:

Then it'll go to # prompt.

The Hard drive is clean as I run the KILLDISK.

I have not tried the above tips but just wondering if anyone of you have encountered this error? Or maybe can someone can shed some knowledge and assistance. I am new to this VICIBOX.

Please advise and help. Thanks for your time.

Please don't hijack threads for your own nefarious purposes, open a new one unless (of course) this was your demonstration of how to post a "tip or trick" for installation as opposed to you asking for help with installation on a specific model of Dell server.

that being said: you could also try installing on a NON Raid drive (your life will be simpler) and then work out the RAIDness later (if the previous suggestion fails you, of course).
Vicidial Installation and Repair, plus Hosting and Colocation
SugarCRM integration - Customization and Add-ons - We Bring It All Together.
http://www.PoundTeam.com # 352-269-0000 # +44 (203) 769-2294 # +506 4001-8914
williamconley
 
Posts: 17433
Joined: Wed Oct 31, 2007 4:17 pm
Location: Davenport, FL (By Disney!)

Re: ViciBox Install Tips and Tricks, etc

Postby Robin009 » Tue May 27, 2014 3:56 pm

hi All,
i have been installing vicibox, when os-install is finished it asked me for rebootnow/later when i click on reboot now after remove the cd from cd-rom then after rebooting it shows the message operating system missing...
???
help me out this
Robin009
 
Posts: 16
Joined: Wed Apr 09, 2014 5:07 pm

Re: ViciBox Install Tips and Tricks, etc

Postby williamconley » Thu Jul 10, 2014 4:58 pm

Robin009 wrote:hi All,
i have been installing vicibox, when os-install is finished it asked me for rebootnow/later when i click on reboot now after remove the cd from cd-rom then after rebooting it shows the message operating system missing...
???
help me out this

don't take out the cd until after you push reboot and it goes dark. then pop out the cd.
Vicidial Installation and Repair, plus Hosting and Colocation
SugarCRM integration - Customization and Add-ons - We Bring It All Together.
http://www.PoundTeam.com # 352-269-0000 # +44 (203) 769-2294 # +506 4001-8914
williamconley
 
Posts: 17433
Joined: Wed Oct 31, 2007 4:17 pm
Location: Davenport, FL (By Disney!)

Re: ViciBox Install Tips and Tricks, etc

Postby devilheart » Thu Dec 01, 2016 11:13 am

hey guys,


when i trying to install dahdi in vicidial server that time i am using the command "make" for installation

but the screen the "make" command not found

so please suggest me how can i install dahdi in vicidial
devilheart
 
Posts: 2
Joined: Thu Dec 01, 2016 10:55 am

Re: ViciBox Install Tips and Tricks, etc

Postby williamconley » Thu Dec 01, 2016 9:45 pm

devilheart wrote:hey guys,


when i trying to install dahdi in vicidial server that time i am using the command "make" for installation

but the screen the "make" command not found

so please suggest me how can i install dahdi in vicidial


This sub-board is for viciBOX which is the Installer for Vicidial and already has dadhi in it. If you install with Vicibox (from Vicibox.com), you do not need to install dahdi as it is already present and functional (unless your install failed!).
Vicidial Installation and Repair, plus Hosting and Colocation
SugarCRM integration - Customization and Add-ons - We Bring It All Together.
http://www.PoundTeam.com # 352-269-0000 # +44 (203) 769-2294 # +506 4001-8914
williamconley
 
Posts: 17433
Joined: Wed Oct 31, 2007 4:17 pm
Location: Davenport, FL (By Disney!)


Return to ViciBox Server Install and Demo

Who is online

Users browsing this forum: No registered users and 12 guests