Call Recordings randomly not starting

All installation and configuration problems and questions

Moderators: gerski, enjay, williamconley, Op3r, Staydog, gardo, mflorell, MJCoate, mcargile, Kumba, Michael_N

Call Recordings randomly not starting

Postby roger.milligan » Thu Jul 30, 2015 7:41 am

Hi

We have recently upgraded a 300 agent (135000 calls per day) call centre to new hardware, OS and new versions of Asterisk, MySQL and ViciDial 2.12 (details below). We are finding that some call recordings are not happening. I have tried numerous things to identify the problem:

Your post looks too spamy for a new user, please remove bad words or non-english text.

See next post for the details that I'm not allowed to post here!

So, after 100s of hours of troubleshooting this one, I'm stuck. Is there a guru out there who can help solve this please?

Thanks very much.

Roger

====
ViciDial: VERSION: 2.12-480a BUILD: 150404-0932 DB schema: 1407 Scratch Install
Cluster:
- 3 x Dell R430 Dual Hex Intel Xeon CPU E5-2620 v3 @ 2.40GHz 24GB RAM (Asterisk & Sangoma USB Timing)
- 2 x Dell R620 Dual Hex Intel Xeon CPU E5-2620 v2 @ 2.10GHz 128GB RAM (VMware with DB, slave, 4 x Apache plus Balance)
Asterisk: v 1.8.28-cert5 MySQL: v 5.6.24 Apache: 2.2.15 CentOS: 6.6
------------------------------------------------------------------------------------------------------
Roger Milligan
Thrive, Cape Town, South Africa.
Mobile: +27 791212325 rogerm(at)thrivedatasolutions(dot)com
roger.milligan
 
Posts: 11
Joined: Sun Jul 19, 2015 12:18 pm

Re: Call Recordings randomly not starting

Postby roger.milligan » Thu Jul 30, 2015 7:43 am

Steps taken to isolate the problem:

1. Sometimes the recording_log.vicidial_id does not match the vicidial_log.uniqueid, especially for a manual ALT dial call. I have added the CALLID to the recording filename and written a StoredProc to fix any mismatches. So it's not a case of the recording being there but not matching. The problem is that Asterisk is not being asked to Originate the call recording.

2. We had a problem with the webservers running out of TCP connections because Centos does not have tcp_tw_recycle set to True (whereas the old SLES servers did). We were getting heaps of 'MySQL connect ERROR:' failures. We have added 2 more web servers and eliminated this problem. Only using 13000 of 28000 available ports now. This solved 75% of the missing recordings problem.
------------------------------------------------------------------------------------------------------
Roger Milligan
Thrive, Cape Town, South Africa.
Mobile: +27 791212325 rogerm(at)thrivedatasolutions(dot)com
roger.milligan
 
Posts: 11
Joined: Sun Jul 19, 2015 12:18 pm

Re: Call Recordings randomly not starting

Postby roger.milligan » Thu Jul 30, 2015 8:02 am

Steps taken to isolate the problem: (Full list. Sorry - the forum would not let me post this earlier - because I spelt debuging with 2 g's!)

1. Sometimes the recording_log.vicidial_id does not match the vicidial_log.uniqueid, especially for a manual ALT dial call. I have added the CALLID to the recording filename and written a StoredProc to fix any mismatches. So it's not a case of the recording being there but not matching. The problem is that Asterisk is not being asked to Originate the call recording.

2. We had a problem with the webservers running out of TCP connections because Centos does not have tcp_tw_recycle set to True (whereas the old SLES servers did). We were getting heaps of 'MySQL connect ERROR:' failures. We have added 2 more web servers and eliminated this problem. Only using 13000 of 28000 available ports now. This solved 75% of the missing recordings problem.

3. I inserted debuging statements in manager_send.php and vdc_db_query.php and also a trigger to trace vicidial_manager inserts. I can confirm that for these missing recordings, manager_send.php is NOT being called by vicidial.php.

4. All campaigns have campaign_recording = 'ALLFORCE' and all users have vicidial_recording_override = 'DISABLED' and vicidial_recording = 1. There are no recording delays set and I've removed any campaign scripts to stop the possibility of recording delays being auto added.

5. The problem is happening randomly for any agent (it seems). An agent has all calls recorded and then randomly it does not record for just one call.

6. Agent browsers are Mozilla Firefox/34.0

7. Happens with RATIO campaigns as well as MANUAL, although it seems to happen more for MANUAL campaigns and for Manual / Alt Dialing within RATIO campaigns.

8. For some of the users on a MANUAL campaign it happens for a block of 5 or 6 calls and then starts recording again without them logging out or changing anything. I have watched an agent while they were in a block of non-recording calls and the only thing I could see is that the Recording Filename displayed on the left of the agent screen remained stuck on the filename of the last successful recording.

9. I have attempted a fix that I call in each loop of AST_VDauto_dial.pl to start recording if it has not happened. [update vicidial_live_agents set external_recording='START' where status='INCALL' and external_recording='' and last_state_change<date_add(now(),INTERVAL -5 second);] This catches most of the problems (and even starts multiple recordings for some calls), but does not solve all of them.

10. Even got the customer to swop out the PCs of some of the agents where this was happening more. Made no difference (as I expected), but we are getting desperate and the customer needs to see us doing whatever we can to get to the bottom of this. They are having to call leads back and re-do a 20-30 minute sales call in order to get a call recording that can prove the sale transaction. Tricky!
------------------------------------------------------------------------------------------------------
Roger Milligan
Thrive, Cape Town, South Africa.
Mobile: +27 791212325 rogerm(at)thrivedatasolutions(dot)com
roger.milligan
 
Posts: 11
Joined: Sun Jul 19, 2015 12:18 pm

Re: Call Recordings randomly not starting

Postby mflorell » Thu Jul 30, 2015 10:23 am

We added a new Agent Debug Logging feature to vicidial recently in svn/trunk.

It is great for tracking down issues like this.
mflorell
Site Admin
 
Posts: 17040
Joined: Wed Jun 07, 2006 2:45 pm
Location: Florida

Re: Call Recordings randomly not starting

Postby roger.milligan » Thu Jul 30, 2015 10:50 am

Thanks Matt. We've seen the Agent Debug Logging and are installing that version on a site tomorrow. I went through the code to see what it does and it looks great. I think that I will have to allow multiple users to be debuged and replace the if ($SSagent_debug_logging == "$user") with some sort of preg_match. (Yes, and watch the table size does not grow too big.)

Do you have any other ideas that we can look at in the meantime - I don't see us upgrading this problem site for at least a week.
------------------------------------------------------------------------------------------------------
Roger Milligan
Thrive, Cape Town, South Africa.
Mobile: +27 791212325 rogerm(at)thrivedatasolutions(dot)com
roger.milligan
 
Posts: 11
Joined: Sun Jul 19, 2015 12:18 pm

Re: Call Recordings randomly not starting

Postby mflorell » Thu Jul 30, 2015 12:34 pm

Usually network issues, workstation issues or some kind of configuration issue causes the kind of problems you mention. It's not always easy to figure out which one it is.
mflorell
Site Admin
 
Posts: 17040
Joined: Wed Jun 07, 2006 2:45 pm
Location: Florida

Re: Call Recordings randomly not starting

Postby okli » Tue Aug 25, 2015 12:20 pm

Have you figured out what the issue was?
This seems similar to the issue we are experiencing:
http://vicidial.org/VICIDIALforum/viewt ... =4&t=34756
okli
 
Posts: 655
Joined: Mon Oct 01, 2007 5:09 pm

Re: Call Recordings randomly not starting

Postby roger.milligan » Wed Aug 26, 2015 1:22 am

Hi Okli

We are still planning to upgrade to the recent version of Vici that will give us the Agent Debug Option, but it's a large call centre an we have not been able to schedule this yet. In the meantime my fix script is catching most of the problems and starting the recording manually. We are just busy taking two more Vici call centers ( 700 & 300 seats) live over the next 4 weeks - so will probably only get to this in October. Will keep you posted.
------------------------------------------------------------------------------------------------------
Roger Milligan
Thrive, Cape Town, South Africa.
Mobile: +27 791212325 rogerm(at)thrivedatasolutions(dot)com
roger.milligan
 
Posts: 11
Joined: Sun Jul 19, 2015 12:18 pm

Re: Call Recordings randomly not starting

Postby okli » Wed Aug 26, 2015 8:55 am

Thanks for the reply Roger.

In the meantime my fix script is catching most of the problems and starting the recording manually

Would you mind sharing some details?

I've temporarily gotten around the issue so far by forcing recording on all DID extensions, but that's far from good, internal transfers also get missing recordings every now and then, looking at the log files, recording originate/request was never issued for these calls.

Have you narrowed down what the cause might be?
okli
 
Posts: 655
Joined: Mon Oct 01, 2007 5:09 pm

Re: Call Recordings randomly not starting

Postby roger.milligan » Wed Aug 26, 2015 9:36 am

Fix script is as in point 9 (above). From the extensive investigations we have done so far, it seems that the request to start recording from the agent (vicidial.php) is never happening. We suspect that it may be some sequence of clicks that the agents are doing or that a call to manager_send.php is not happening for some reason or failing if it is called. That's where the new Agent Debug functionality will be useful in tracking this down.
------------------------------------------------------------------------------------------------------
Roger Milligan
Thrive, Cape Town, South Africa.
Mobile: +27 791212325 rogerm(at)thrivedatasolutions(dot)com
roger.milligan
 
Posts: 11
Joined: Sun Jul 19, 2015 12:18 pm

Re: Call Recordings randomly not starting

Postby ccabrera » Fri Feb 16, 2018 2:10 pm

Sorry for necrobumping, but this is totally related to this topic.

We've run into several issues where exactly this happens: agent interface never sends request to start recording. This makes the Vicidial ajax debug log useless as the AGC never sends the request to Vicidial, so there is nothing to record.

I believe the only way would be to do a browser console debug.

Has anyone else moved forward into this kind of log? Does anyone know any tools I could use to help me find this issue? I haven't found yet a way to store the Firefox console log into a file for further analysis, but maybe you guys have found something which I haven't.

Regards,
Christian Cabrera
Enlaza Comunicaciones - Vicidial Partner
Mexico City
ccabrera
 
Posts: 104
Joined: Fri Jan 14, 2011 7:53 pm
Location: México, DF

Re: Call Recordings randomly not starting

Postby williamconley » Fri Feb 16, 2018 3:44 pm

ccabrera wrote:Sorry for necrobumping, but this is totally related to this topic.

We've run into several issues where exactly this happens: agent interface never sends request to start recording. This makes the Vicidial ajax debug log useless as the AGC never sends the request to Vicidial, so there is nothing to record.

I believe the only way would be to do a browser console debug.

Has anyone else moved forward into this kind of log? Does anyone know any tools I could use to help me find this issue? I haven't found yet a way to store the Firefox console log into a file for further analysis, but maybe you guys have found something which I haven't.

Regards,


1) Welcome to the Party! 8-)

2) As you are obviously new here, I have some suggestions to help us all help you:

When you post, please post your entire configuration including (but not limited to) your installation method (7.X.X?) and vicidial version with build (VERSION: 2.X-XXXx ... BUILD: #####-####).

This IS a requirement for posting along with reading the stickies (at the top of each forum) and the manager's manual (available on EFLO.net, both free and paid versions)

You should also post: Asterisk version, telephony hardware (model number is helpful here), cluster information if you have one, and whether any other software is installed in the box. If your installation method is "manual/from scratch" you must post your operating system with version (and the .iso version from which you installed your original operating system) plus a link to the installation instructions you used. If your installation is "Hosted" list the site name of the host.

If this is a "Cloud" or "Virtual" server, please note the technology involved along with the version of that techology (ie: VMware Server Version 2.0.2). If it is not, merely stating the Motherboard model # and CPU would be helpful.

Similar to This:

Vicibox X.X from .iso | Vicidial X.X.X-XXX Build XXXXXX-XXXX | Asterisk X.X.X | Single Server | No Digium/Sangoma Hardware | No Extra Software After Installation | Intel DG35EC | Core2Quad Q6600

3) You have not posted any configuration options relevant to the issue. You merely asserted a missing data call. Without reason to believe the data call should have happened in the first place, that does not call for any troubleshooting. Please try again. For instance: How sure are you that the recording isn't supposed to happen automatically based on a campaign settings? Or is this when the agent pushes the "record" button?

4) Drop these randomly throughout the process you believe to be failing:
Code: Select all
if (document.QuizDebug>4) { console.trace(); }
if (document.QuizDebug>0) { console.log(arguments.callee.name+"| "+VARIABLENAMEHERE); }


Be sure you set "document.QuizDebug=5" somewhere or use a different test. (Or leave off the if completely, but then you'll have to go back and delete them all when done to reduce load on the agent session. If you care. ;)
Be sure you are in Javascript code when you drop them.
Be sure you do not interrupt an if or any other type of statement (ie: don't put this between the "if (test)" and the {execution}, which is a common newbie mistake and breaks the if by substituting your new if for the execution section which now will never fire)
You don't need trace and arguments.callee.name in the same section usually. And remember that VARIABLENAMEHERE must actually exist when you call it or it'll hard stop javascript. document.variables are global, but anything declared with "var" in front of it is limited to the function in which it was called.

5) Happy Hunting 8-)
Vicidial Installation and Repair, plus Hosting and Colocation
SugarCRM integration - Customization and Add-ons - We Bring It All Together.
http://www.PoundTeam.com # 352-269-0000 # +44 (203) 769-2294 # +506 4001-8914
williamconley
 
Posts: 17433
Joined: Wed Oct 31, 2007 4:17 pm
Location: Davenport, FL (By Disney!)

Re: Call Recordings randomly not starting

Postby ccabrera » Fri Feb 16, 2018 4:19 pm

Hello William:

Thanks for the reply. Even though I have been on these forums for some years now, this is the first time you've schooled me with the usual "welcome to the party". I know I deserved that for not stating the obvious (for me).

My install is a vanilla Vicibox 7 with VERSION: 2.14-650a BUILD: 180111-1544 with Xeon 2.4 Ghz, 16G RAM and dual 10K RAID1 disks, serving about 20 agents at most. I'm certain the agent interface isn't firing up the recording because I've already done the following:

1. I've set CALL RECORDING = FORCE and ROUTING INITIATED RECORDING = Y inside the campaign in question. Since that move, all problems with automatic call recording were solved, and now only the manual calls are the ones that randomly have problems.
2. I've already used the Ajax Debug Log. By comparing the log for a call WITH recording to a call WITHOUT recording, I've found that the difference is that the latter one is not sending a MonitorConf event. AFAIK, that means the agent interface is not even requesting the recording start.
3. I've checked the Apache logs to see if they match with the Ajax Debug (they do), so I know it's not a problem whether Vicidial receives the request and Ignores it.

Also, I've made sure no other processes/webpages are being run in the browser (FIrefox), since I've read that sometimes, Javascript intensive tabs inside the browser may cause this issue.

I've checked the Vicidial server up and down, and the only thing so far I'm missing is the client side. The big, big problem, is that as this topic says, calls are not being recorded "randomly", so I cannot reproduce it easily. Sometimes it happens 10 times a day, sometimes none.

This is one of those errors that I'll have to personally go to the center and (literally), walk behind the agents to see what happens on their console, so that's why I was looking for something to debug. Maybe there was a hidden option with enables javascript debug inside the AGC, so any low level debugs anyone may know could be useful before I go to the call center war zone.

Your suggestion requires modifying the code from inside Vicidial, which as you suggest, is risky. I was trying to find any kind of command inside the browser's console that might allow me to collect data without being behind the agent (and just download the log every hour or so) for further analysis. Something like a "JS pcap file" is what I was looking for, in case someone knew anything about it.

Regards,
Christian Cabrera
Enlaza Comunicaciones - Vicidial Partner
Mexico City
ccabrera
 
Posts: 104
Joined: Fri Jan 14, 2011 7:53 pm
Location: México, DF

Re: Call Recordings randomly not starting

Postby williamconley » Fri Feb 16, 2018 4:27 pm

Vicibox 7 ... point what? 7.0.1 vs 7.0.4 are very different (bug-wise).

Why Vicibox 7 fresh now when Vicibox 8 is out (serious question, not giving you a hard time, the answer may be enlightening).

"Randomly not starting" is the ticket header. Are you saying it sometimes works and sometimes doesn't? If not, then this ticket hijack was probably inappropriate.

If you have campaign/ingroup settings to force, it's not related to the agent session requests. Those are initiated by the agi scripts inherently if I recall correctly.

So are you saying that all-force is on and NO recordings happen?
Vicidial Installation and Repair, plus Hosting and Colocation
SugarCRM integration - Customization and Add-ons - We Bring It All Together.
http://www.PoundTeam.com # 352-269-0000 # +44 (203) 769-2294 # +506 4001-8914
williamconley
 
Posts: 17433
Joined: Wed Oct 31, 2007 4:17 pm
Location: Davenport, FL (By Disney!)

Re: Call Recordings randomly not starting

Postby ccabrera » Fri Feb 16, 2018 4:48 pm

Hi again William,

It's ViciBox v.7.0.3-160505. The system was installed a couple of years ago, and 7.0.3 was the most current then. We try to keep the SVN updated since bugs get fixed, but we don't reinstall every time a new Vicibox comes out.

And you are right: manual calls randomly do not start. All adaptive/ratio dialing calls get recorded properly, since they are initiated by the server. However, manual calls (which get triggered by the agent interface) sometimes do not. I believe we only lose about 3% of manual calls, which isn't much from a statistical viewpoint, but for this particular campaign, it means everything.

And for the final sentence: not exactly. Allforce is on, and that forces all auto initiated calls (which is fine), but some manual calls fail to trigger recording. When calls go missing, there isn't even a manager request which triggers the recording.

I know all of this sounds strange, but it is what it is, and after reading this whole post, I know I'm not the only one. I just want to find a proper way to debug so I can point fingers and solve whatever is on my side.

Regards,
Christian Cabrera
Enlaza Comunicaciones - Vicidial Partner
Mexico City
ccabrera
 
Posts: 104
Joined: Fri Jan 14, 2011 7:53 pm
Location: México, DF

Re: Call Recordings randomly not starting

Postby williamconley » Fri Feb 16, 2018 4:55 pm

Let's zero in a bit. Only manual dialed calls are failing. Good place to start, and obviously valuable information. ;)

How are these calls initiated? Vicidial agent interface manual dial without a lead? Do they use the dial override field or the phone numer field? Or are they dialing directly from their phones without an agent screen? Can you prove this (any evidence to support your assertion, logically speaking, is useful on all fronts ... never go with "i'm sure").

Are these calls in the same campaign as the autodialed calls that do record?

Do these calls coincidentally NOT match a lead while the others DO match a lead?

Has this been happening for the entire two years, or only recently?

And you HAVE read this, right?
Routing Initiated Recording -This option, if enabled, allows you to have the call routing script for Outbound auto-dial calls trigger the agent call recording instead of the agent screen. This option will only work if the recording option is set to ALLCALLS or ALLFORCE. This will not work with agent manual dialed calls. Default is N for disabled.
Vicidial Installation and Repair, plus Hosting and Colocation
SugarCRM integration - Customization and Add-ons - We Bring It All Together.
http://www.PoundTeam.com # 352-269-0000 # +44 (203) 769-2294 # +506 4001-8914
williamconley
 
Posts: 17433
Joined: Wed Oct 31, 2007 4:17 pm
Location: Davenport, FL (By Disney!)

Re: Call Recordings randomly not starting

Postby ccabrera » Fri Feb 16, 2018 5:12 pm

William,

By your questions I notices I left out one detail: this campaign uses custom fields, in case this opens up a new case. More on the answers to come:

williamconley wrote: How are these calls initiated?

By clicking in the "Manual dial" link at the bottom of the AGC. Then they enter the number and have the search box ticked. Every call must match a lead, otherwise the custom fields used will not appear and then the call flow cannot continue, since they NEED the custom fields to ask specific questions to the client.

Vicidial agent interface manual dial without a lead?

Lead is searched for when dialing manually (the search box is ticked)

Do they use the dial override field or the phone numer field?

They use the phone code and phone number field (the ones at the top of the manual dial windows)

Or are they dialing directly from their phones without an agent screen?

No, they are not. I've already disabled direct softphone dialing.

Can you prove this (any evidence to support your assertion, logically speaking, is useful on all fronts ... never go with "i'm sure").

Yes. There are log records which prove how the call was made: manual dialing (not override), but only the records from the recording_log table are missing.

Are these calls in the same campaign as the autodialed calls that do record?

Yes. Everything I've shared is regarding only 1 campaign. This campaign uses RATIO for most of the calls but sometimes, agents dial manually to retry a specific number. Also, I'm sure the call is not matching another lead in another list/campaign because otherwise it wouldn't show up the correct custom fields, and that would make the call useless since the agent wouldn't be able to collect the correct information for this call.

Do these calls coincidentally NOT match a lead while the others DO match a lead?

No. Everything needs to match a lead. Otherwise it won't be dialed.

Has this been happening for the entire two years, or only recently?

Can't tell. Just until recently this center started having a very strict campaign which requires all sales to be recorded and delivered individually, so that's where they began to notice.

And you HAVE read this, right?

Of course. I mentioned previously that since enabling that option, all auto calls are being properly recorded, but as the documentation states, it doesn't work for manual calls which is where I have issues.


As extra information, this is how I get which calls are missing:

SELECT * FROM vicidial_log AS l
LEFT JOIN recording_log AS r ON l.uniqueid = r.vicidial_id
WHERE campaign_id = 'XXXXX AND r.vicidial_id IS NULL AND STATUS = 'SALE'
ORDER BY call_date DESC LIMIT 100

And also I've looked through the agiout and asterisk full log and there are no traces of the 8309 extension, which is the one I use for recording (just in case you were wondering there was no log of the call but that maybe the file was indeed created but not indexed).
Christian Cabrera
Enlaza Comunicaciones - Vicidial Partner
Mexico City
ccabrera
 
Posts: 104
Joined: Fri Jan 14, 2011 7:53 pm
Location: México, DF

Re: Call Recordings randomly not starting

Postby williamconley » Fri Feb 16, 2018 5:42 pm

Of course. I mentioned previously that since enabling that option, all auto calls are being properly recorded, but as the documentation states, it doesn't work for manual calls which is where I have issues.


So ... you DID turn that option off, right?

As extra information, this is how I get which calls are missing:


So, correlate those and see if there's a pattern of any sort. One agent who never has this problem but does have manual dials ... anything. A pattern of values in the records (all from the same zip code?). Seriously. anything that can be a pattern or rule can help break the code. ;)

Apache logs contain requests (no post data), but may show a request landed. Debug code can be added to the ajax responder php page in case it's a crash after a request but before execution. Vicidial_manager table may have entries that failed to execute if it was after php that the fail occurred. But if the fail is IN the javascript of the agent screen, that's a different story. You may need to get a snapshot of a java console of a successful manual dial and see where you may add some code (perhaps even with extra ajax calls so the server can centrally log the progress of manual dial call requests, line by freakin line). Not a lot of manual dialed calls, so that's not too obtrusive.

Shot in the dark:

What if there is a special character in the custom fields for these records ... that could crash javascript and stop processing of further requests. And of course, that's not logged because javascript doesn't log uncaught exceptions, by definition they are uncaught and not loggable.
Vicidial Installation and Repair, plus Hosting and Colocation
SugarCRM integration - Customization and Add-ons - We Bring It All Together.
http://www.PoundTeam.com # 352-269-0000 # +44 (203) 769-2294 # +506 4001-8914
williamconley
 
Posts: 17433
Joined: Wed Oct 31, 2007 4:17 pm
Location: Davenport, FL (By Disney!)

Re: Call Recordings randomly not starting

Postby ccabrera » Fri Feb 16, 2018 6:04 pm

William,

I think we are understanding different things from the Routing Initiated Recording. As I understand it, this makes that all auto dialed calls become responsibility of the server, instead of the agent screen, but manual dial calls keep being triggered by the AGC.

If I turn this off, that would make that ALL calls (auto or manual) get triggered by the AGC, and thus increasing the amount of calls I will not have recorded. If I turn it on, at least I know the auto calls will surely get recorded, so I only have to worry about the manual ones.

As a proof of this concept: before turning that option ON, I had several auto calls which didn't get recorded properly. Since turning that setting ON, I no longer have auto calls without recording, only manual ones. So in my experience, this settings helps me much more than it hurts me, it just doesn't solve my problem completely.

Now, about your shot in the dark, I think you might be into something. Since our client names use letters as á é í ó ú, I cannot guarantee those characters are being properly sanitized and it could be that as you are implying, maybe something crashes JS without anyone of us noticing. I'll search through the special chars of the missing calls and report back.


Thanks for your question pitching. It allows me to think outside of our usual standards.

Regards,
Christian Cabrera
Enlaza Comunicaciones - Vicidial Partner
Mexico City
ccabrera
 
Posts: 104
Joined: Fri Jan 14, 2011 7:53 pm
Location: México, DF

Re: Call Recordings randomly not starting

Postby williamconley » Fri Feb 16, 2018 7:24 pm

I'm not talking about understanding. I'm talking about TESTING. It's a recent feature. Bugs are common in recent features. Test.
Vicidial Installation and Repair, plus Hosting and Colocation
SugarCRM integration - Customization and Add-ons - We Bring It All Together.
http://www.PoundTeam.com # 352-269-0000 # +44 (203) 769-2294 # +506 4001-8914
williamconley
 
Posts: 17433
Joined: Wed Oct 31, 2007 4:17 pm
Location: Davenport, FL (By Disney!)

Re: Call Recordings randomly not starting

Postby ccabrera » Fri Feb 16, 2018 8:13 pm

I did test, and so far my test results have proven my theory, so it is a working and useful feature which I believe should be set up as a default in Vicidial, instead of it being off by default.

Also, I ran the same query as before but without limiting it to a particular campaign or to a particular status. Without accounting for NA, DROP, LRERR, ERI, etc (which wouldn't record calls as they are no answer status), I have ZERO missed recordings coming from auto calls since I enabled the Routing Initiated Recording option. This has been for the past 3 weeks.

Regarding the special chars idea. I've found some records that usually have the Ñ character but in the DB they got switched to a #, which might be interpreted as a comment. However, not all records have this, so I'm still searching for a pattern.
Christian Cabrera
Enlaza Comunicaciones - Vicidial Partner
Mexico City
ccabrera
 
Posts: 104
Joined: Fri Jan 14, 2011 7:53 pm
Location: México, DF

Re: Call Recordings randomly not starting

Postby williamconley » Fri Feb 16, 2018 11:30 pm

my test results have proven my theory


You're assuming I know what this is. Also: When you say there are no missing recordings if this feature is on while we're in a ticket stating that there are missing recordings, you're making me wonder if you should see a psychiatrist.

I'd like to assume you're just paraphrasing and leaving out those tiny unnecessary technical details like "no missing recordings for AUTODIAL". But I know you wouldn't skip technical explanations while asking for technical support, as that would be counterproductive and you don't hate me that much. So I'm back to doubtin your sanity.

Wanna clear that up for me? 8-) (PS: You can't call me anything my kids haven't already called me ... lol)
Vicidial Installation and Repair, plus Hosting and Colocation
SugarCRM integration - Customization and Add-ons - We Bring It All Together.
http://www.PoundTeam.com # 352-269-0000 # +44 (203) 769-2294 # +506 4001-8914
williamconley
 
Posts: 17433
Joined: Wed Oct 31, 2007 4:17 pm
Location: Davenport, FL (By Disney!)

Re: Call Recordings randomly not starting

Postby thephaseusa » Wed Feb 21, 2018 5:32 pm

Version: 2.14b0.5
SVN Version: 2872
DB Schema Version: 1527
ViciBox v.7.0.4| Asterisk 11.25.1-vici |
4 Box Cluster of 1 Database, 1 Asterisk, 1 Web, & 1 Archive Server.
Fundraising Call Center

Excellent thread! Very important too. It’s happened to me once or twice that a sale was made, and I really needed to listen to the recording of it, and I couldn’t find it because it didnt get recorded. Vicidial is the best there is as far as I’m concerned. And if anyone can help you configure it correctly it’s William Conley. But isn’t it fair to say there are occassions, however rare, where a call does not get recorded, through no fault of your own configuration, and through no fault of vicidial?

John
thephaseusa
 
Posts: 246
Joined: Tue May 16, 2017 2:23 pm

Re: Call Recordings randomly not starting

Postby ccabrera » Wed Feb 21, 2018 5:57 pm

@thephaseusa, I believe you are correct. Everything seems to be in order, but in some very, very rare ocassions, calls just simply do not get recorded, and I'm still trying to figure out why.

@williamconley, I stated previously that I used to have both manual and auto dial recordings missing, but after enabling the Routing Initiated Recording, I no longer have missing auto/autodial recordings, but I still have SOME manual recordings missing.

I tried what you suggested and still couldn't find any pattern (like special chars inside the customer data) which stops manual calls from (very rare ocassions) being recorded.


TLDR; Everything is now fine for autodial recordings. Only about 2% of manual dialing recordings are missing.

The only idea I got, was to add a different manual dial prefix inside the campaign, and inside that prefix I trigger a MixMonitor, so Asterisk records everything manually dialed at least once. Most of the times I end up being with double recordings, but whenever there is one sale recording missing I can always go into this "recording backup" and find the one I need.

This is not a solution, but rather the only way I've found to deal with the problem. Ideally, there would be a setting that starts the recording from the server side even for manual calls, but so far, this is the best I've got.

If any of you guys can think of another idea, I'm open for suggestions.

Regards
Christian Cabrera
Enlaza Comunicaciones - Vicidial Partner
Mexico City
ccabrera
 
Posts: 104
Joined: Fri Jan 14, 2011 7:53 pm
Location: México, DF

Re: Call Recordings randomly not starting

Postby williamconley » Wed Feb 21, 2018 6:15 pm

You could sponsor upgrading the existing autodial-only function/feature to also encompass manual dial. (I know that's not the most fun thing to hear, but that would get it done.)

Alternately, without rhyme or reason for the failure it'll be hard to pin down.
Vicidial Installation and Repair, plus Hosting and Colocation
SugarCRM integration - Customization and Add-ons - We Bring It All Together.
http://www.PoundTeam.com # 352-269-0000 # +44 (203) 769-2294 # +506 4001-8914
williamconley
 
Posts: 17433
Joined: Wed Oct 31, 2007 4:17 pm
Location: Davenport, FL (By Disney!)

Re: Call Recordings randomly not starting

Postby mflorell » Tue May 22, 2018 8:02 pm

I just added Manual-Dial-compatible Routing Initiated Recordings, you must enable setting at the campaign level and have a 0 recording delay. Please upgrade to the newest svn/trunk revision and try it out!
mflorell
Site Admin
 
Posts: 17040
Joined: Wed Jun 07, 2006 2:45 pm
Location: Florida

Re: Call Recordings randomly not starting

Postby thephaseusa » Tue May 22, 2018 9:54 pm

Thanks M. Florell! This should prove a popular revision))

J. Merritt
thephaseusa
 
Posts: 246
Joined: Tue May 16, 2017 2:23 pm

Re: Call Recordings randomly not starting

Postby frequency » Mon Jul 16, 2018 3:09 pm

mflorell wrote:I just added Manual-Dial-compatible Routing Initiated Recordings, you must enable setting at the campaign level and have a 0 recording delay. Please upgrade to the newest svn/trunk revision and try it out!


Which revision had these changes? I am running 2980 which is basically mid May release.
frequency
 
Posts: 81
Joined: Mon Jun 13, 2016 11:18 am

Re: Call Recordings randomly not starting

Postby williamconley » Mon Jul 16, 2018 3:43 pm

frequency wrote:
mflorell wrote:I just added Manual-Dial-compatible Routing Initiated Recordings, you must enable setting at the campaign level and have a 0 recording delay. Please upgrade to the newest svn/trunk revision and try it out!


Which revision had these changes? I am running 2980 which is basically mid May release.

Code: Select all
cd /usr/src/astguiclient/trunk; svn info;


Has a line for:
Code: Select all
Last Changed Date: 201X-XX-XX 17:31:33 -0400 (Wed, 22 XXX 201X)


I will go out on a limb here and suggest that if your SVN last changed date is on or before 5/22/18 ... you need to upgrade.

8-)
Vicidial Installation and Repair, plus Hosting and Colocation
SugarCRM integration - Customization and Add-ons - We Bring It All Together.
http://www.PoundTeam.com # 352-269-0000 # +44 (203) 769-2294 # +506 4001-8914
williamconley
 
Posts: 17433
Joined: Wed Oct 31, 2007 4:17 pm
Location: Davenport, FL (By Disney!)


Return to Support

Who is online

Users browsing this forum: No registered users and 27 guests