Confirm correct ISO

All installation and configuration problems and questions

Moderators: gerski, enjay, williamconley, Op3r, Staydog, gardo, mflorell, MJCoate, mcargile, Kumba, Michael_N

Confirm correct ISO

Postby c20xh2 » Sat Nov 30, 2019 11:14 am

Hey guys,

I have to re-install an old version of Vicidial but I'm not sure how to confirm what iso was used at the time.

This is what the system is currently running :

VERSION: 2.14-620a
BUILD: 170623-2142


I'm looking at http://download.vicidial.com/iso/vicibo ... e/?C=M;O=D but can't find out how to confirm what ISO I should grab.
c20xh2
 
Posts: 75
Joined: Mon Feb 20, 2017 2:28 am

Re: Confirm correct ISO

Postby williamconley » Sat Nov 30, 2019 11:38 am

Loading with an older version of the installer is ONLY necessary to match an Asterisk Version requirement. Older versions of Vicidial do not support later versions of asterisk, so using an installer that will install the correct version of Asterisk is simpler than re-installing an older asterisk after using a newer installer (much simpler, in fact).

Your best bet is to check the install.pl file and see which versions of asterisk are supported UNLESS you were using Asterisk 13 already.

Aside from matching the Asterisk version during installation, there is no other requirement for using any particular installer. They will all provide a suitable environment for Vicidial, and you can upgrade/downgrade the Vicidial version in the svn trunk folder post-install OR restore all your files from the prior installation. Most of the time if there is no customization involved it's easier to install the latest version, certify that it works, then overwrite the database and UPGRADE the database to match the fresh install, then recertify it. Now you have the latest install and all your data. If you can't upgrade for some reason (eg: if you created custom fields or have some custom scripts that are locked to a specific Vicidial version), just modify the SVN trunk to match and run install.pl again to get the Vicdial base code to match, then restore all your custom files and database over the freshly installed system. Then your Database will match the SVN revision level and your custom code will match all the non-customzed code as well.

If you need to run an older installer, just use the latest one with the proper asterisk version included. For instance, 6.0.4, 7.0.4, 8.0.1, 8.1.2 ... since you're already in Vicidial version 2.14 you can likely use 7.0.4. However, I'd still suggest you upgrade during your reinstall instead. It'll make maintaining the system easier in the long run by keeping your OS manageable as well since older OpenSuSE repositories are often Gone.
Vicidial Installation and Repair, plus Hosting and Colocation
SugarCRM integration - Customization and Add-ons - We Bring It All Together.
http://www.PoundTeam.com # 352-269-0000 # +44 (203) 769-2294 # +506 4001-8914
williamconley
 
Posts: 18977
Joined: Wed Oct 31, 2007 4:17 pm
Location: Davenport, FL (By Disney!)


Return to Support

Who is online

Users browsing this forum: Google [Bot] and 57 guests