Inbound not working for Amazon

All installation and configuration problems and questions

Moderators: gerski, enjay, williamconley, Op3r, Staydog, gardo, mflorell, MJCoate, mcargile, Kumba, Michael_N

Inbound not working for Amazon

Postby arunabh » Fri Nov 01, 2019 5:27 am

Hi,

This is Arunabh from India. We are running two outbound processes and I am looking after the vicidial server. The outbound is running fine and good, but the issue is with the inbound DID call landing because we are going to run one for sale Amazom process where customers will call into our purchased DID number.

I have configured the Inbound DID,In-group and campaign following thoroughly the managers manual, but the confusion is with carrier configuration.

Following is the inbound carrier details:

[testcarrier23492]
disallow=all
allow=ulaw
allow=g729
type=friend
username=DialitesInbound
fromuser=DialitesInbound
secret=Di&thy8dh2487
host=103.94.86.53
context=trunkinbound
insecure=port,invite
dtmfmode=rfc2833
usecallerid=yes
trustrpid=no
sendrpid=yes
requirecalltoken=no
nat=yes

Global String:

TESTSIPTRUNK23492=SIP/testcarrier23492

Dialplan Entry:

exten => _492.,1,AGI(agi://127.0.0.1:4577/call_log)
exten => _492.,2,Dial(${TESTSIPTRUNK23492}/${EXTEN:3},,tTor)
exten => _492.,3,Hangup

I am using vicibox 7
Version : 2.14-718a

As I am new to setup inbound campaign please suggest.

I have tried the following dial plan but it is not working:

exten => DID-number,1,Ringing
exten => DID-number,2,Wait(1)
exten => DID-number,3,Answer
exten => DID-number,4,AGI(agi://127.0.0.1:4577/call_log)
exten => DID-number,5,AGI(agi-DID_route.agi)
exten => DID-number,6,Hangup

The issue is that when agents logged in campaign and I called the DID it is not landing.
DID: All USA
DID No: 12xxxxx6003

I have called the DID from different connection and Skype also but the result is the same.

Please suggest as I need to complete it ASAP.

And please suggest me where I should put the dialprefix ? Is that same as outbound ?
arunabh
 
Posts: 1
Joined: Thu Oct 03, 2019 12:39 am

Re: Inbound not working for Amazon

Postby ambiorixg12 » Fri Nov 08, 2019 10:35 am

First thing you need to do it is enable the asterisk sip de bug and verify if the INVITE request from the DID provider is reaching your server sip set debug on
Asterisk and FreePBX expert / Twilio & PHP / Python MYSQL developer.

Personal site : http://asterisk-voip.com/
ambiorixg12
 
Posts: 338
Joined: Tue Sep 17, 2013 10:35 pm

Re: Inbound not working for Amazon

Postby ed123 » Tue Nov 26, 2019 11:43 pm

Hi,, you just post your sip credentials and everyone can see it..hope its a dummy one.. :)
ed123
 
Posts: 279
Joined: Mon Mar 15, 2010 9:19 pm

Re: Inbound not working for Amazon

Postby williamconley » Wed Nov 27, 2019 6:20 am

There are TWO basic steps for inbound:

First you must set the carrier to send the calls to your server. This can't be done in Vicidial, although "Registration" of the Vicidial server may be part of the process. To test for this you can use sip debug or an asterisk console to see if you get ANY activity in the console or the sip debug during a call attempt.

The second step is to set the inbound carrier in Vicidial to have "context=trunkinbound" in the Account Settings. This will turn control of the call over to the Vicidial scripting/call handling system. This puts the call into the "[trunkinbound]" context in extensions.conf. The only purpose of that context is to route the call to the Vicidial agi scripts. There is NO need or use to creating your own dialplan for an inbound call since that's NOT vicidial and you obviously want to use Vicidial.

Happy Hunting! 8-)

PS: Moving this Support question to the Support board where it belongs. :?
Vicidial Installation and Repair, plus Hosting and Colocation
Newest Product: NonDisruptive Lead Loader for Enterprise Vicidial Clusters.
(IE: Keep on dialing even while loading large lists!)
http://www.PoundTeam.com # 352-269-0000 # +44(203) 769-2294
williamconley
 
Posts: 19396
Joined: Wed Oct 31, 2007 4:17 pm
Location: Davenport, FL (By Disney!)


Return to Support

Who is online

Users browsing this forum: Google [Bot] and 38 guests